Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).
Project Subscriptions
Advisories
| Source | ID | Title |
|---|---|---|
EUVD |
EUVD-2022-0789 | Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS). |
Github GHSA |
GHSA-3cqr-58rm-57f8 | Arbitrary Code Execution in Handlebars |
Fixes
Solution
No solution given by the vendor.
Workaround
No workaround given by the vendor.
References
History
Fri, 09 Oct 2026 09:30:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Metrics |
ssvc
|
Projects
Sign in to view the affected projects.
Status: PUBLISHED
Assigner: mitre
Published:
Updated: 2026-10-08T21:13:55.415Z
Reserved: 2020-09-30T00:00:00.000Z
Link: CVE-2019-20920
Updated: 2024-08-05T03:00:18.770Z
Status : Modified
Published: 2020-09-30T18:15:17.927
Modified: 2026-10-08T22:16:54.603
Link: CVE-2019-20920
OpenCVE Enrichment
No data.
EUVD
Github GHSA